Developing software in the Real World

Installing 32 bit packages on Ubuntu 14.04

This had me stumped for a bit, so I’ve written it down. If you have a 64 bit version of Ubuntu and want to install a 32-bit package, you simply add :i386 to the end of the package name like this:

However, this didn’t initially work for me as apt-get couldn’t find the package:

It turned out that my installation only had the 64 bit architecture configured which you can tell by running:


Note that there are no foreign architectures, which is the problem.

The solution is to add the i386 architecture first:

That’s better! Now we need to run an update:

Don’t forget this update! I did and wondered why I still had the problem…

Now the installation of the 32-bit package works:

All done!

7 thoughts on “Installing 32 bit packages on Ubuntu 14.04

  1. sudo apt-get install libstdc++6:i386
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    bind9-host : Depends: libbind9-140 (= 1:9.10.3.dfsg.P4-8ubuntu1) but it is not going to be installed
    Depends: libdns162 (= 1:9.10.3.dfsg.P4-8ubuntu1) but it is not going to be installed
    Depends: libisc160 (= 1:9.10.3.dfsg.P4-8ubuntu1) but it is not going to be installed
    Depends: libisccfg140 (= 1:9.10.3.dfsg.P4-8ubuntu1) but it is not going to be installed
    imagemagick : Depends: imagemagick-6.q16 (= 8:6.8.9.9-7ubuntu5.1)
    liblouisutdml-bin : Depends: liblouisutdml6 but it is not going to be installed
    libsane : Depends: libgphoto2-6 (>= 2.5.2) but it is not going to be installed
    libstdc++6:i386 : Depends: gcc-5-base:i386 (= 5.3.1-14ubuntu2) but it is not going to be installed
    shared-mime-info : Depends: libxml2 (>= 2.7.4) but it is not going to be installed
    upower : Depends: libimobiledevice6 (>= 0.9.7) but it is not going to be installed
    Depends: libplist3 (>= 1.11) but it is not going to be installed
    E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Thoughts? Leave a reply

Your email address will not be published. Required fields are marked *